Back button presented on "Post to Timeline" screen and is not functional

the “Post to Timeline” screen has a back button instead of an “X” as shown in the sample app. The back button on that screen is also not functional which makes going back to the “NewsFeed” screen impossible at the moment.

To give you a better explanation, I’m not presenting or pushing any Upstra UIKit screen, but merely passing reference to the main screen on tap of each tab in the below screen. I also have no control over the UIKit screen either. Although I’m using a navigation controller for the main container in which I’m passing references for SDK Screens.

The “Post to Timeline” screen with a back button where it should be an “X” button to close the modal.

(Edit) I would like to add additional information as follows:
Video 1 - Without Navigation: I have removed my navigation controller and as you can see back buttons from all Upstra screens after push are hidden.

Video 2 - Without Navigation: Still no navigation controller added to the container but you can see when tapping on a pencil it presents a controller with a navigation bar on top. and even it can push to new screens and back button there is visible. It implies that the SDK is presenting a navigation controller, not a view controller.

Video 3 - With Navigation: As I have added my navigation controller to the container back buttons on all pushed screens are visible but still on the new post screen it’s not working because that button presenting and pop will not work on the present. Also, the navigation bar of my controller is not overlapping any component since you can check in previous videos.

Thank you for your inquiry and sorry for the late response.
May we ask a question? Which platform and OS version that you faced the symptoms?
Thank you very much.

Upstra UIKit Version: ‘1.5.3’
Upstra SDK Version: 4.2.0
OS Version: Catalina 10.15.5
Xcode: 11.5
CL Tools: 11.5

A navigation bar issue was fixed on version 1.7.0 and we suggest upgrading to the latest version 1.8.1, which included customization enhancement and bug fixes.

I found an issue while upgrading from 1.5.3 to 1.8.1, the details are as follow:
This happens when I upgrade to any version from 1.5.3

Please advise.

We had tried installing over pod install command on a couple of Xcode cl tool versions – 11.3.1. 11.5.1, 12.2.
As a result, the installation works fine and doesn’t found the issue.

One thing I’m guessing is the current gem version isn’t compatible with nanimo, a serialization tool, version.
Please following this link, I hope it helps.
CocoaPods/CocoaPods#6124 (comment)

Still facing the issue, have updated Ruby, Brew, and Gems.

Another solution is installing manually. Can you please try the following steps?

  1. remove Upstra from your workspace (by removing pod 'UpstraUIKit' from podfile and run pod install )
  2. download Upstra 1.8.2 from this link
  3. unzip and drag UpstraUIKit.xcframework , EkoChat.xcframework and Realm.xcframework to workspace manually
  4. clean and build

Navigation issue resolved after update to 1.8.2, thank you for your help!