Got compiler error when trying to run sample app

Please find iOS status for Sample App. We are still getting the same errors. I believe SDK project is not matching. I am downloading sdks from below link -

The SDK also contains a live video project which i am trying to play with.

Hi @touchaponk ,

The sample app project needs to integrate the AmitySDK.xcframework & Realm.xcframework that we provide in the same zip. For integration, please follow the steps in “Manual Installation” section from Documentation.
After integrating, perform the clean build and run the sample app.

Hi @nishan thank you for the response. I’ve tried that but still get the same error. I’m using the sample ap and here’s my exact zip file:!AvhH0IQOdKjPhI4DhCR0lqki8Y2daQ

We don’t see the requires framework

  • AmitySDK.xcframework
  • Realm.xcframework

placing in /Frameworks folder.

Step to run SampleApp.

Download the SDK from this link Install Chat SDK - Amity Docs

You will see the required frameworks are already in /Frameworks folder.

What you need to do next is…go to SampleApp project and run.

It should work fine. We’ve just tested on our side, moment ago.