Linking AmitySDK manually requires us to link Realm manually

Linking AmitySDK manually requires us to link Realm manually as well → Not possible to store those dependencies on github as the files are >100mb (would require us to use GIT lfs), if we include the dependency through SPM we get a build error

For installation via manual download.

  1. If you would like to commit those frameworks into Git (which is usual). LFS is the way to go. It will benefit your project in the long run for storing binary / large files in the repository.

  2. You could opt-out not committing frameworks into Git, so this way you have to do extra work by getting those files somewhere outside of Git.

Hi there, thanks a lot for answering the questions. Do you have a timeline when the SPM support for the AmitySDK is available? As our project is using SPM we would need to manually add the AmitySDK and therefore also Realm. As our setup requires to have a running app setup on Github we cannot strip those SDKs from the repository. Also the usage of GIT-lfs is currently not planed. The Issue is that case is that we can push the Realm to git as it’s simply too large with about 400mb. We tried to integrate the Amity SDK manually and adding Realm 5.5.0 via SPM was not successful. Do you have any tips how we can get it integrated given the constraints we have?

Hey, on our common slack channel you mention that you already have SPM on your Q3 roadmap. This is great! Talking to our iOS academy we found that Amity not supporting SPM is a blocker for us. LFS currently is not an option for us. I think for the next 1-2 weeks we can go with manually including the framework (omiting it from the repository) but after that we would need SPM support. Would it maybe be possible to accelerate that on your side?

Hey @nrewik, about SPM we have problems using it (screenshot attached), in the beginning it worked fine but now there seems to be an issue with the checksum. Could you help us out?


Hi sorry about that, we do some experiment on SwiftPM, so it might affect at v5.1.0 tag.

Could you please clear cache and try again?

  1. Clean build folder.
  2. Delete derived data.
  3. run rm -rf ~/Library/Caches/org.swift.swiftpm/

Tested a moment ago, it works fine.

Screen Shot 2564-07-01 at 16.28.26

@nrewik Ahh thanks for the quick reply, will try! :rocket:

One more question regarding SPM, since you are already rocking the topic, do you plan to also introduce SPM for the AmityUIKit? We would really love to only have dependencies via SPM :slight_smile:


We now support SPM for most of the products. For AmityUIKit, you can read the doc here :point_down:.

** Edited: Modify the link.

Boom! Thanks, sorry for first asking then looking! :slight_smile: