Installation via SPM is getting failed

I was trying to install Amity’s UIKit SDK (latest) via SPM as stated in your documentation guide here but the process fails because the Package.swift manifest is missing from the repository.
Anything missing? Please help asap

Hello, to install iOS UIKit opensource, we would recommend using Git Submodule instead: ? and to get the latest update you can follow the steps here: iOS UIKit Installation Guide - Amity Docs

Please let us know if you have further questions.

Tried using git module, i am getting realm errors on predicate

Why can’t i use SPM?
RealmSwift using on the UIKit is not latest?
Kindly share response fast

Any help team? Little urgent @amitysupport


Given the issue you’re facing, may I inquire whether you are currently using Realm in your project? If you are, we recommend resetting the Package Cache of your Application Target. Here are the steps:

  1. If you are installing AmityUIKit for the first time, you can skip this step.
  2. Select your App Target in the Xcode Project.
  3. Go to the File menu in Xcode.
  4. Navigate to Packages.
  5. Choose Reset Package Cache.

please let us know if you still facing the issue.

Best Regard
Support team

Hi @amitysupport:
Still the same, I did reset package cache and cleared derived data. still not working.

can you confirm the realm version being used? I was using realm 10.42.3. Once I added UIKit I removed realm from my project

@amitysupport anything I am missing?


Your version seems fine now. I’ll pass it on to the team to double-check for you.

Best Regard
Support team

1 Like

HI team @amitysupport ,

Anything found?

Hi team @amitysupport :

Can you guys confirm the realm version being used? and any release I can expect with fix?


Upon further investigation by our team, we would like to confirm whether you are currently using RealmSwift in your project. AmityUIKit includes RealmSwift as a dependency, and we recommend removing the existing Realm version you are using. Instead, utilize the one automatically installed by AmityUIKit. This RealmSwift/Realm will be installed through SharedFrameworks.

Please proceed with this adjustment and let us know if it resolves the issue. If you encounter any challenges or have additional questions, feel free to provide more details, and we will assist you accordingly.

Best Regard
Support team

Hi @amitysupport :

I am not using realm swift library in my project. The only issue is when I call filter its give me error. Can u confirm the realm version used?

please refer attachemts



We acknowledge the issue you’re facing with the filter method from RealmSwift. Our team is currently investigating this matter, and we appreciate your patience.

In the meantime, we recommend using one of the alternative approaches:

  1. Utilize the filter(_ predicateFormat: String, _ args: Any...) method with a predicate format string.
  2. Consider adding a new filter(_ predicate: NSPredicate) method in the RealmCollection extension, as demonstrated below.

We will keep you updated on any progress regarding this issue. If you have further questions or concerns, feel free to reach out.

Best Regard
Support team

1 Like

Update: It appears that the issue is related to a third-party component, specifically the realm dependency. We will investigate this matter further and implement a solution in a future version. In the meantime, kindly utilize the alternative approaches we’ve supplied.

Sure @amitysupport. Once released a fix please let me knw.

Certainly, @psp2 I will keep you informed once the fix is released. Thank you for your patience.

1 Like

@amitysupport Any update on the release?

@psp2 I’ll check with our team about your issue and will update you as soon as possible.

Hello @psp2 , After consulting with the relevant team, our iOS UIKit has been updated. You can check the details and instructions for the updated version at this link: Installation Guide for iOS UIKit.